Brazil - Itaú - Delays approving payments
Incident Report for D24
Resolved
This incident has been resolved.
Posted Jul 28, 2021 - 11:37 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 28, 2021 - 09:06 UTC
Identified
We would like to inform you that we are observing a delay on the bank's end while approving transactions
paid with Itaú in Brazil.
We will continue monitoring for any improvements.
Posted Jul 28, 2021 - 05:00 UTC
This incident affected: Payment methods (Brazil - Itaú).